Kategorien
Allgemein

Veeam – Failed to get stat on Errno: 2. Unable to get device for path:

Nachdem entfernen eines Laufwerks kann Veeam die Sicherung eines Linux Systems nicht mehr durchführen und „failed“ mit der Fehlermeldung:

14:45:40 [error] Can’t get info for file [/srv/syslog.backup]
14:45:40 [error] Failed to retrieve mount point for [/srv/syslog.backup]

Soweit auch klar, das Verzeichnis gibt es nicht mehr! Allerdings scheitere ich auch daran die zu sichernden Dateien via Veeam Client entsprechend anzupassen.

Die Lösung ist wie immer pragmatisch, einfach mit sqlite3 CLI die Veeam Datenbank öffnen und entsprechend das Verzeichnis in der Datenbank suchen und entfernen.

sqlite3 /var/lib/veeam/veeam_db.sqlite

sqlite> select * from JobFilters;

{d6a30132-26d4-41ee-aa1c-dd7242d82e24}|{7487c858-4c06-421f-b284-aa90a1ce3608}|1|5|/var|
{df8a1212-ce58-4e28-a866-c5ccaa23ec6c}|{7487c858-4c06-421f-b284-aa90a1ce3608}|2|5|/srv/syslog.backup|

delete from JobFilters where id=“{df8a1212-ce58-4e28-a866-c5ccaa23ec6c}“;

Und schon funktioniert das Backup wieder wie gewohnt. Da ich auf den Support Seiten von Veeam keine passende Lösung gefunden habe wird’s hier veröffentlicht. Ein entsprechendes Ticket dazu wurde eröffnet.

Kategorien
Allgemein

Unifi Controller Firewall Regel-erstell Bug

Seit inzwischen etwas mehr als einem Jahr setze ich in einigen Netzwerken recht erfolgreich Hardware von Unifi und entsprechend auch deren Controller ein. Ich bin inzwischen ein kleiner Fan von der Unifi Infrastruktur, sie funktioniert gut und ist zu leistbaren Preisen verfügbar – wenn auch zeitweise nur mit längeren Lieferzeiten.

Gestern hatte ich mal wieder das „Vergnügen“ mit dem Unifi Support zu chatten, ich wollte einen vermeintlichen Bug den ich im Interface zum Erstellen von Firewall Regeln gefunden habe melden.

Was soll ich sagen, eine Stunde später war ich am Ende meiner Nerven aber irgendwie habe ich es dann doch geschafft die werte Dame davon zu überzeugen den Fehler weiter zu melden…

Der Fehler ist eigentlich schnell erklärt und nachvollziehbar – bei mir auf zwei unterschiedlichen Cloud Key’s mit ebenfalls zwei Unterschiedlichen Firmware Versionen:

Cloud Key und Controller mit der Vorversion
Cloud Key mit aktueller Firmware und Controller Version

Erstellt man eine einfache Firewall Regel welche den TCP Verkehr zu einem bestimmten Host dessen IP Adresse angegeben wird frei schaltet und speichert diese, dann erscheint nach dem Speichern im selben Dialog beim Editieren keine IP Adresse mehr. Die Regel funktioniert zwar, kann aber nicht mehr zuverlässig verändert werden.

Testregel – sämtlicher TCP Verkehr zum Server 8.8.8.8 erlauben
Nach dem Speichern wird unter Address/Port Group der Default angezeigt, IP Address ist leer.

Für den Fall dass jemand langweilig ist kommt hier noch der Mitschnitt vom Chat mit Unifi – ich hoffe es wird verständlich warum ich mich darüber geärgert habe…! 🙂

(09:17:35 AM) Manfred: Hello,
I think I found a bug!
When I crate a firewall rule wich allows all TCP traffic to a specific IP address, the IP address will be removed from the rule management interface after I save the rule.
(09:20:37 AM) Customer Service: Sorry to keep you waiting! All of our agents are currently assisting other customers, but we’ll be with you shortly! You’re welcome to explore our help center, which might have a solution for you. Take a look. https://help.ubnt.com/hc/en-us
(09:23:37 AM) Customer Service: We are experiencing unusually high support volume. We thank you for your patience and we will be with you shortly.
(09:28:25 AM) *** Anna G joined the chat ***
(09:28:30 AM) Anna G: Hi there. Let me check it for you.
(09:28:41 AM) Manfred: hi anna, please 🙂
(09:30:08 AM) Manfred: Current Version5.9.29 (Build: atag_5.9.29_11384)
(09:33:19 AM) Anna G: Which browser are you using?
(09:33:55 AM) Manfred: chrome
(09:37:16 AM) Anna G: Have you tried to clear browser history and cache?
(09:38:18 AM) Manfred: yes
(09:39:58 AM) Anna G: Please try accessing the controller in incognito mode of your chrome browser.
(09:40:29 AM) Manfred: ok, one moment…
(09:42:19 AM) Manfred: same error – after saving the ip address is empty in the field
(09:42:29 AM) Manfred: did you try that on your test system?
(09:43:34 AM) Anna G: Not yet. Please give me a moment to check this with my internal team.
(09:44:35 AM) Manfred: please create a new „wan out“ rule with accept tcp to an external ip address, save it and edit the rule again – should have an empty ip address field in destination field…
(09:50:29 AM) Anna G: On which OS is the controller installed?
(09:50:50 AM) Manfred: cloud key 🙂
(09:51:04 AM) Manfred: UCK.mtk7623.v0.12.2.ac6742e.181220.1824
(09:51:27 AM) Anna G: Have you tried rebooting the CK?
(09:52:09 AM) Manfred: no, have you tried to create a rule on your controller?
(09:53:13 AM) Anna G: Could you please reboot the CK and let me know if the issue persists?
(09:53:52 AM) Manfred: if i reboot the controller this chat will be ended or isn’t it so?
(09:54:32 AM) Manfred: to check if it’s bug or a problem on my system you would only have to do 5 clicks in the firewall settings and you could see if it happens on your site too or just on mine…
(09:55:03 AM) Manfred: I will check that on a second controller now – if the error is there too I will not have to reboot mine or?
(09:57:45 AM) Anna G: Any updates?
(09:57:55 AM) Manfred: second controller – same problem there…
(09:58:05 AM) Manfred: Visitor uploaded: after_saving.png
(09:58:06 AM) Manfred: Visitor uploaded: before_saving.png
(09:58:06 AM) Manfred: Visitor uploaded: rule_overview_with_test-rule.png
(09:58:37 AM) Manfred: would it be possible for you to check that on your test controller now?
(09:59:21 AM) Anna G: on which OS is this second controller installed?
(09:59:40 AM) Manfred: uck
(09:59:54 AM) Manfred: same version
(10:00:17 AM) Anna G: Can you please reboot this second cloud key and let me know if the issue resolves?
(10:00:32 AM) Anna G: I need to provide this information to my team.
(10:00:45 AM) Manfred: you are joking?
(10:02:38 AM) Anna G: Please check out the known issues mentioned in the release note:
https://community.ubnt.com/t5/UniFi-Updates-Blog/UniFi-Network-Controller-5-10-12-Stable-has-been-released/ba-p/2665341
(10:03:20 AM) Anna G: Refreshing/rebooting the controller should resolve any display issues reported after upgrading.
(10:05:55 AM) Manfred: i make a restart but am not really happy with the situation!
actually, i’m trying to help you identify a bug in your product and help you fix it, the easiest way would be to reproduce the problem on a test system.
the problem exists exactly the same after the restart as before.
for my part i have already spent more time to report the bug here and am a bit annoyed in the meantime.
please take this information and pass it on to your team, i will pass it on for my part on my blog.

(10:06:58 AM) Manfred: second cloud key with same problem has this cloud key version:
UCK.mtk7623.v0.12.2.ac6742e.181220.1824
(10:07:13 AM) Manfred: and controller version:
5.9.29-11384-1
(10:07:14 AM) Anna G: Thank you for the update!
(10:07:49 AM) Anna G: I will escalate this.
(10:07:56 AM) Manfred: thank you

Unifi Chat Transcript – 11.02.2019

Kategorien
Allgemein

Vergessenen Veeam Restore Point aushängen (Linux/cli)

Gelegentlich passiert es dass man nach dem Rücksichern von Dateien vergisst den Restore Point wieder auszuhängen. Ein klassischer „umount“ führt hier nicht zum Ziel weil veeam selbst noch auf dem Mount drauf hängt und diesen blockiert.

Es muss also via veeam der umount erfolgen – das klappt wie folgt:

#!/bin/bash

if [ -x „/usr/bin/veeamconfig“ ]; then
TIME=$(date „+%H%M“)
if [ $TIME -gt 1900 ]; then
VEEAMSESSION=$(/usr/bin/veeamconfig session list|grep „Mount“|grep „Running“|awk ‚{print $3}’|tr -d „{}“)
if [ „$VEEAMSESSION“ ]; then
/usr/bin/veeamconfig session stop –id $VEEAMSESSION
fi
fi
fi

Dieses kleine Script läuft bei mir stündlich ab, wird aber erst nach 19:00 Uhr aktiv und hängt verbliebene Mount-Sessions wieder aus.

Kategorien
Allgemein

Windows 7 Druckerverbindung nicht möglich Fehler 0x00000bc4

Ein PC der über Jahre ohne Probleme mit einem Drucker verbunden ist kann plötzlich nicht mehr drucken, das Löschen und Wiederherstellen der Verbindung über den UNC Pfad \\prod1\pdf schlägt fehl. Eine Verbindung via IP Adresse \\192.168.1.1\PDF ist allerdings noch möglich!

Im Eventlog von Windows findet sich mal wieder überhaupt nichts, auch sonst kein wirklicher Hinweis woher das Problem stammen könnte.

Nachdem ich alle Verweise auf den Drucker in der Registry gelöscht und den PC neu gestartet habe bekomme ich folgenden Fehler zu sehen: 0x00000bc4

Unglaublich aussagekräftig, hier lobe ich mir die Linux Welt – gewöhnlich vernünftige Fehlermeldungen in den Logs und falls das nicht reicht dreht man das Debugging einfach hoch und lässt sich mit Meldungen überfluten. Mit ein wenig Hirnschmalz kommt man dann meist schnell an’s Ziel.

Nicht so bei meinem „Lieblingsbetriebssystem“ – hier muss man sich via trial and error stundenlang quälen und wertvolle Lebenszeit vergeuden.

So geschehen am gestrigen Tag und heute Morgen, immerhin habe ich eine Lösung für das Problem gefunden und möchte es hier für künftige Einsätze und andere Gequälte festhalten:

Diesen Registry Key löschen:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print\Providers

Und anschließend einmal neu starten, anschließen lässt sich die Druckerverbindung wieder herstellen.

Eine andere vorgeschlagene Lösung hat bei mir nicht funktioniert:

ipconfig /flushdns

Für den Fall der Fälle schadet es aber nicht den mal auszuführen. Die Namensauflösung lief bei mir aber immer sauber durch, ein Ping auf prod1 war immer problemlos möglich und wurde zur korrekten IP aufgelöst.

Kategorien
Allgemein

3-Ware 9750-4i RAID 1 – Plattentausch und Filesystem auf 4 TB vergrößern

Der Unterschied zwischen günstigen und teuren RAID Controller Karten stellt sich oft erst in seltenen Momenten dar – aktuell bei mir gerade mal wieder bei einem 3-Ware RAID Controller Modell 9750-4i. Ein RAID 1 aus zwei 1 TB Platten wurde etwas zu klein und musste durch größere 4 TB Platten erweitert werden.

In der Theorie wäre meine Vorgehensweise so:
– Die 1. Platte mit 4 TB Platte tauschen
– RAID Rebuild mit neuer Platte starten und abwarten
– Die 2. Platte mit 4 TB Platte tauschen
– RAID Rebuild erneut starten und abwarten
– anschließend Volumes und Filesysteme vergrößern und fertig…

In der Praxis scheitert das Ganze beim Vergößeren der RAID1 Unit – der 3Ware Controller kennt zwar theoretisch einen Befehl dafür, das klappt aber wohl nur wenn man z.B: bei einem RAID5 eine weitere Platte ins System hängen will. Mit einem RAID1 funktioniert es schlicht so nicht. Die Hilfe von tw_cli ist nicht wirklch sehr hilfreich, oder wer kann mit „[disk=<p:-p..>]“ wirklich viel anfangen?

Der Trick mit dem es funktioniert ist das komplette RAID1 zu zerpflücken und ein Laufwerk zu entfernen bevor die Daten auf die neue Platte kopiert werden:

  1. RAID1 Array aufteilen. Es entstehen zwei Arrays mit dem gleichen Inhalt und der gleichen Größe.
    tw_cli /c0/u1 migrate type=single
    

    Die bisherige Partitionen /dev/sd* welche auf das RAID1 Einheit /u1 zeigen bleiben erhalten. Man bekommt eine neue Einheit /u2 welche aus der zweiten Platte besteht.

  2. Jetzt können wir die zweite Platte/Einheit /u2 komplett vom Controller entfernen und anschließend die größere Platte einbauen.
    tw_cli /c0/u2 del
    
  3. Die neue Platte im Controller anlegen, das geht im BIOS oder im fertig gestartetem System mit folgendem Befehl:
    tw_cli /c0 add type=single disk=1
    

    die neue Platte/Einheit /u2 sollte jetzt die volle Plattengröße anzeigen (4 TB).

  4. Jetzt werden alle Daten von der alten Platte /u1 auf die neue /u2 übertragen

    dd if=/dev/sdc of=/dev/sdd bs=64k
    

    Wer in einer zweiten Konsole watch -n60 "kill -USR1 $(pgrep ^dd)" startet, bekommt alle 60 Sekunden beim dd Befehl den aktuellen Fortschritt angezeigt. Bei 183 MB/s waren meine knapp 1TB an Daten in etwas mehr als 1,5 Stunden kopiert. Von den gelegentlichen Neustarts die nötig sind ist dies die einzige längere Downtime die man hinnehmen muss.

  5. Die verbliebene alte Festplatte kann jetzt aus dem Controller entfernt und durch die neue 4TB Platte ersetzt werden.
    tw_cli /c0/u1 del
    
  6. Und jetzt kommt der spannende Teil, wir erstellen aus einer Platte die noch nicht in Verwendung ist und der 4 TB Platte mit den Daten /u2 ein neues RAID
    tw_cli /c0/u2 migrate type=raid1 disk=1
    

    Der Rebuild sollte jetzt in Kürze starten:

    watch „tw_cli /c0 show“

    beobachtet den Rebuild Prozess…

  7. Anschließend muss man nur noch die Partitionen vergrößern

    parted /dev/sdd resizedisk 3 2000G

    Vergrößert die 3. Partition wobei die 2000G nicht die Größe sondern den Endpunkt der Partition darstellen!

  8. Und das Filesystem anpassen

    resize2fs -p /dev/sdd3

    Der Parameter „-p“ vergrößert das Filesystem auf das maximal mögliche – je nach Größe der Partition.

Ich hoffe dem einen oder anderen Hilft diese Anleitung weiter, mir wird sie künftig auf jeden Fall etwas Zeit einsparen! 🙂

Kategorien
Allgemein

ZPL nachträglich verändern

Wer ein Zebra Etikett von seinem Vorgänger übernommen hat und keinerlei Daten vom Original hat, dem Nützt der ZebraDesigner nur wenig – vorhandene ZPL Dateien können darin lieder nicht importiert werden.

Wie kann man nun Etiketten am einfachsten verändern ohne gleich das Rad neu erfinden zu müssen?

Das Online-Tool „Labelary“ hilft hier recht gut weiter!

Mit dem Viewer kann man sich den bestehenden ZPL Code anzeigen lassen und recht einfach Anpassungen vornehmen, leider nicht mit dem Komfort eines Zebra Designers – dafür kann man allerdings den ZPL Code direkt verändern und sieht die Auswirkungen nach einem Klick auf „Redraw“.

Parallel halte ich meist den ZPL Programming Guide bereit – ein Manko von ZPL ist dass man sich deren Syntax beim besten Willen nicht merken kann… 😉

Was mir jetzt noch fehlt ist ein Konverter für ZPL nach TSPL und umgekehrt, gerade der BarTender Editor von unseren TSC Druckern ist deutlich komfortabler als jener für die Zebra Drucker. Generell bin ich ein Freund von TSPL, die Druckersprache ist einfach viel schöner zu lesen! Schade nur dass TSC es seit Jahren nicht schafft, das geplante Druckmodul zum Verbauen in Spendeanlagen, auf den Markt zu bringen.

Kategorien
Allgemein

Owncloud zu Nextcloud Migrationsproblem mit Mysql DB Verbindung

Nachdem sich Nextcloud von Owncloud abgesplittet hat und die Entwicklung dort Fahrt aufgenommen hat, wollte ich heute eine Owncloud 9 Version nach Nextcloud 11 migrieren.

Der Direkte Pfad wird nicht empfohlen – hier die Empfehlung von Nextcloud:

  • ownCloud 8.0.x -> ownCloud 8.1.x -> ownCloud 8.2.x -> Nextcloud 9.0.x -> Nextcloud 10.0.x
  • ownCloud 8.2.x -> Nextcloud 9.0.x -> Nextcloud 10.0.x
  • ownCloud 9.0.x -> Nextcloud 9.0.x -> Nextcloud 10.0.x
  • ownCloud 9.1.x -> Nextcloud 10.0.x -> Nextcloud 11.0.x

In meinem Fall habe ich erst Owncloud auf die Version 9.1.4 hoch gezogen und dann migriert.

Die Migration hat allerdings nicht auf Anhieb geklappt – nach dem Einspielen der Dateien und dem Anpassen der Konfiguration bekam ich folgende Fehlermeldung:

Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [2006] MySQL server has gone away in /var/www/nextcloud/lib/private/DB/Connection.php:59
Stack trace:
#0 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(429): OC\DB\Connection->connect()
#1 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(389): Doctrine\DBAL\Connection->getDatabasePlatformVersion()
#2 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(328): Doctrine\DBAL\Connection->detectDatabasePlatform()
#3 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(621): Doctrine\DBAL\Connection->getDatabasePlatform()
#4 /var/www/nextcloud/lib/private/DB/Connection.php(142): Doctrine\DBAL\Connection->setTransactionIsolation(2)
#5 /var/www/nextcloud/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php(172): OC\DB\Connection->__construct(Array, Object(Doctrine\DBAL\Driver\PDOMySql\Driver), Object(Doctrine\DBAL\Configuration), Object(Doctrine\Common\EventManager))
#6 /var/www/nextcloud/lib/private/DB/ConnectionFactory.php(121): Doctrine\DBAL\DriverManager::getConnection(Array, Object(Doctrine\DBAL\Configuration), Object(Doctrine\Common\EventManager))
#7 /var/www/nextcloud/lib/private/Server.php(415): OC\DB\ConnectionFactory->getConnection(‚mysql‘, Array)
#8 /var/www/nextcloud/3rdparty/pimple/pimple/src/Pimple/Container.php(113): OC\Server->OC\{closure}(Object(OC\Server))
#9 /var/www/nextcloud/lib/private/AppFramework/Utility/SimpleContainer.php(103): Pimple\Container->offsetGet(‚DatabaseConnect…‘)
#10 /var/www/nextcloud/lib/private/ServerContainer.php(89): OC\AppFramework\Utility\SimpleContainer->query(‚DatabaseConnect…‘)
#11 /var/www/nextcloud/lib/private/Server.php(1029): OC\ServerContainer->query(‚DatabaseConnect…‘)
#12 /var/www/nextcloud/lib/private/legacy/db.php(57): OC\Server->getDatabaseConnection()
#13 /var/www/nextcloud/lib/private/User/Database.php(232): OC_DB::prepare(‚SELECT `uid`, `…‘)
#14 /var/www/nextcloud/lib/private/User/Database.php(280): OC\User\Database->loadUser(“)
#15 /var/www/nextcloud/lib/private/User/Manager.php(140): OC\User\Database->userExists(“)
#16 /var/www/nextcloud/lib/private/User/Session.php(197): OC\User\Manager->get(“)
#17 /var/www/nextcloud/lib/private/Log.php(282): OC\User\Session->getUser()
#18 /var/www/nextcloud/lib/public/Util.php(159): OC\Log->log(3, ‚User backend OC…‘, Array)
#19 /var/www/nextcloud/lib/private/legacy/user.php(146): OCP\Util::writeLog(‚core‘, ‚User backend OC…‘, 3)
#20 /var/www/nextcloud/lib/base.php(742): OC_User::setupBackends()
#21 /var/www/nextcloud/lib/base.php(1074): OC::init()
#22 /var/www/nextcloud/console.php(56): require_once(‚/var/www/nextcl…‘)
#23 /var/www/nextcloud/occ(11): require_once(‚/var/www/nextcl…‘)
#24 {main}PHP Warning: call_user_func() expects parameter 1 to be a valid callback, class ‚OC\Log\File‘ not found in /var/www/nextcloud/lib/private/Log.php on line 299

Irgend ein Problem mit der Verbindung zur Datenbank – nachdem Owncloud zuvor mit der gleichen Config funktioniert hat und ich die Zugangsdaten mehrfach geprüft habe, kam ich zu dem Entschluß dass ich es mal mit einer frischen Datenbank versuchen könnte.

Also einfach die config/config.php verschmissen und neue Daten eingetragen. Wenige Sekunden später lief dann eine leere Instanz von Owncloud (keine User) mit den vorhandenen Files.

Als nächstes  habe ich einen Dump der alten Datenbank erstellt und diesen über die neue Datenbank gespielt. Eigentlich würde ich erwarten dass jetzt gleich wie vorher nicht mehr funktioniert. Falsch geraten – das Upgrade auf Nextcloud 10 ließ sich ohne Schwierigkeiten installieren.

Anschließend noch die Kür mit dem Upgrade auf Nextcloud 11 und beendet ist die kleine Upgrade-Orgie.

Warum das Ganze? Weil ich Kalender und Kontakte synchronisieren will… 🙂

PS: Im Zuge der Umstellung habe ich dann auch gleich von mysql zu mariadb gewechselt.

Kategorien
Allgemein

Thunderbird/Lightning Fehlermeldung – die binäre Komponente konnte nicht geladen werden

Eine der wohl schrägsten Fehlermeldungen die ich in letzter Zeit erhalten habe und die mich nicht so wirklich auf weiter gebracht hat ist die folgende:

Die für Lightning benötigte binäre Komponente konnte nicht geladen werden, da vermutlich nicht zueinander passende Versinoen verwendet werden. Aktuell haben sie Lightning 4.7.4 installiert, sollten aber eine Version aus der 4.7er-Serie verwenden.

Beim genauen Lesen dürfte auffallen dass die Version 4.7.4 durchaus der 4.7er Serie entspringt  – die Meldung also Schwachsinn ist.

Nach langem Suchen und verschiedenen Tests habe ich dann den Fehler gefunden, er dürfte sehr speziell sein und tritt nur in der bei uns eingesetzten Konstellation auf. Die Besonderheit ist dass unsere Thunderbird User Profil Ordner auf einem Netzlaufwerk (Samba Server) liegen. Alle von den Benutzern auf diesen Laufwerken erstellten Dateien bekommen per Default die Berechtigung 600 also RW zugewiesen – können also nur vom User selbst gelesen und beschrieben werden.

Und genau hier liegt das Problem – die eine DLL Datei die im extensinos/components Ordner von Lightning liegt braucht zusätzlich das execute-bit gesetzt!

Nach einem chmod +x auf der Datei „calbasecomps.dll“ verschwand die Fehlermeldung.

 

Kategorien
Allgemein

Doppelter Zeilenumbruch nach Update auf Thunderbird 45

Wer mit dem Phänomen kämpt dass nach dem Upgrade auf Thunderbird 45 beim Schreiben einer Mail nach dem Drücken von Enter ein doppelter Zeilenumbruch erfolgt, der sollte sich unter Extras/Einstellungen/Verfassen den Punkt Allgemein genauer ansehen.

Hier ist eine neue Option hinzugekommen – „Eingabetaste erzeugt neuen Absatz, falls Formatierung Absatz verwendet wird“.

tb

Bei eingeschalteter Option kann man mit Strg+Enter einen normalen einfachen Zeilenumbruch erzeugen und mit Enter einen Doppelten – also einen Absatz.

Kategorien
Allgemein

Insulin Angel Crowdfunding

IMG_5646Vor kurzem habe ich hier auf meinem Blog von meinem Besuch bei Insulin Angel auf der Cebit berichtet…

Heute kommt die aktuelle Meldung rein dass das Crowdfunding kommende Woche starten wird!

Mehr über die Crowdfunding Kampagne gibt es hier http://www.insulinangel.com/indiegogo/

Für all jene die mit dem Begriff Crowdfunding nichts anfangen können eine schnelle Erklärung: Mittels Crowdfunding kann eine Startup-Firma auf einfache Art und Weise den Produktionsprozess für die ersten Serien anstoßen, jeder Teilnehmer am Crowdfunding bestellt quasi ein oder mehrere Modelle des noch nicht am Markt erhältlichen Produkts vor und bekommt das dann meist zu einem günstigeren Preis bei Marktstart. Mehr Details dazu gibt es hier bei Wikipedia!