Ubuntu 18.04 interface rename Problem nach Update von systemd/udev auf Version 237-3ubuntu10.26

Ubuntu 18.04 interface rename Problem nach Update von systemd/udev auf Version 237-3ubuntu10.26

Heute Morgen wie gewöhnlich die letzten Sicherheitsupdates von Ubuntu 18.04 installiert und einen System-Neustart eingeleitet. Was bei vielen meiner betreuten Systeme gestern ohne irgendwelche Wehwehchen über die Bühne gegangen ist, machte bei einem Firewall-System sofort Schwierigkeiten.

Keinerlei Netzwerkverbindungen waren mehr möglich, nach ein wenig Suche im System stelle sich heraus dass die interfaces nicht mehr korrekt zugeordnet waren!

Bis heute Morgen lief auf dem System systemd und udev mit folgender Versions Nummer:
237-3ubuntu10.25
Nach dem Update waren diese und ein paar weitere Pakete auf die Version
237-3ubuntu10.26
angehoben worden.

Der Fehler äußert sich im Logfile durch folgenden Meldung:

fehlerhaftes System (/var/log/syslog):
systemd-udevd[423]: Error changing net interface name ‚eth1‘ to ‚eth0‘: File exists

und hier der Log vom funktionierenden System (/var/log/syslog):
Sep 4 13:10:09 brutus kernel: [ 4.518507] igb 0000:04:00.0 rename2: renamed from eth0
Sep 4 13:10:09 brutus kernel: [ 4.565081] igb 0000:07:00.0 eth0: renamed from eth1

Ganz eindeutig fehlt hier der Rename des Interfaces eth0 bevor eth1 zu eth0 umbenannt wird, daher gibt es einen Konflikt der nicht aufgelöst werden kann und die Zuordnung der vier Netzwerkschnittstellen wird dann nicht korrekt durchgeführt.

Einen entsprechenden Bug-Report habe ich bei Canonical bereits auf gemacht:
https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1842651
Ihr dürft ihn gerne upvoten damit der Fehler schneller behoben wird! 🙂

In der Zwischenzeit habe ich mir durch Installation der älteren Pakete geholfen, folgende musste ich manuell herunterladen und installieren:

libacl1_2.2.52-3_amd64.deb
libsystemd0_237-3ubuntu10.25_amd64.deb
libudev1_237-3ubuntu10.25_amd64.deb
systemd_237-3ubuntu10.25_amd64.deb
systemd-sysv_237-3ubuntu10.25_amd64.deb
udev_237-3ubuntu10.25_amd64.deb

Die Installation erfolgt nach dem Download durch folgenden Befehl:

dpkg -i libacl1_2.2.52-3_amd64.deb libsystemd0_237-3ubuntu10.25_amd64.deb libudev1_237-3ubuntu10.25_amd64.deb systemd_237-3ubuntu10.25_amd64.deb systemd-sysv_237-3ubuntu10.25_amd64.deb udev_237-3ubuntu10.25_amd64.deb

Bei i386’er Systemen bitte entsprechend das amd64 durch i386 austauschen!

Anschließend lief nach einem Neustart mein System wieder korrekt, von weiteren Updates sehe ich erstmal bis zur Behebung des Bugs ab.

05.09.2019 Inzwischen wird an einem Bugfix gearbeitet, ich hoffe er funktioniert und wird bald ausgerollt!

Schreibe einen Kommentar

Menü schließen