Categories: Linux

Error ‚You cannot ‚ALTER‘ a log table if logging is enabled‘ on query. Default database: ‚mysql‘. Query: ‚ALTER TABLE slow_log

Gelegentlich kommt es vor dass bei einem Master/Slave MySQL System folgende Fehlermeldung im „SHOW SLAVE STATUS“ angezeigt wird:

Error ‚You cannot ‚ALTER‘ a log table if logging is enabled‘ on query. Default database: ‚mysql‘. Query: ‚ALTER TABLE slow_log

Man kann also die slow_log Table nicht verändern während das Logging aktiviert ist…

Somit muss es ausgeschaltet werden damit die Veränderung an der Tabelle greift und anschließend kann es wieder aktiviert werden.

Das klappt wie folgt – im MySQL am Slave anmelden und anschließend den Slave stoppen.

STOP SLAVE;

In unserem fall müssen wir den slow_query_log deaktivieren:

SET GLOBAL slow_query_log = ‚OFF‘;

Jetzt kann man den Slave wieder starten:

START SLAVE;

Die Fehlermeldung sollte verschwunden sein und der Log wird wie gewohnt abgearbeitet:

SHOW SLAVE STATUS\G

Und jetzt können wir noch das Logging reaktivieren:

SET GLOBAL slow_query_log = ‚ON‘;

Leider tritt das Problem immer wieder mal nach einem MySQL Update auf…

Manfred

Recent Posts

Proxmox VE 9 – Netzwerk Interface Zuordnung ändern

Ich bin es gewohnt unter /etc/systemd/network/10-nic0.link die Zurodnung des Netzwerk Interfaces zu seinem Namen "nic0"…

2 Monaten ago

Nextcloud – PHP Imagick Fehlermeldung

Nextcloud liefert in den Administrationseinstellungen gelegentlich diese Fehlermeldung: PHP Imagick-Modul Das PHP-Modul "imagick" in dieser…

3 Monaten ago

Postsible: Warum ich meinen eigenen Mail-Server gebaut habe

Ein Mail-Server-Setup das nicht nervt — weil alle anderen Lösungen nervig waren "Wie schwer kann…

7 Monaten ago

M$ & Office 365 haben mir gerade wieder Lebenszeit gekostet – Error 0-2048 (0)

<Sarkasmus>Die besten Softwareentwickler arbeiten bei Microsoft!</Sarkasmus> Als Endanwender würde ich mir Fehlermeldungen erwarten die aussagekräftig…

8 Monaten ago

ESET ohne Web Access Protection Modul installieren

Auf einem Linux Server braucht man eventuell das WAP Modul von ESET nicht, der Weg…

11 Monaten ago

Veeam Agent for Linux ignoriert .vdi Files

Auf einem Linux System mit installiertem Veeam Agent wird auf File-Level Basis eine Sicherung des…

2 Jahren ago